在Deepin上安装DaVinci Resolve

本文最后修改于 191 天前,部分内容可能已经过时!

达芬奇是一款全平台支持的调色软件。现在加入了剪辑功能,再加上Fusion的助力,可以把这个软件当做一个强大的后期聚合软件来使用。但是官方对于Linux支持的定义只包括了CentOS,对于Debian系的说明并不明确。所以在尝试之后特地来记录一下其在Deepin(基于Debian sid)上面的安装过程

一、获取DaVinci Resolve

前往 https://www.blackmagicdesign.com/cn/products/davinciresolve/ 获取安装文件(.zip)。免费用户可以使用DaVinci Resolve,感觉对个人来说够用了。在点击下载之后填写一个表格即可得到链接。

二、补全依赖

DaVinci的依赖比较复杂。因此在安装之前请先调整好自己系统的依赖关系以满足DaVinci安装程序和运行的需要。

注:网络上有脚本可以把DaVinci的安装程序转换为.deb,安装更方便。最后讲。

需要事先安装的依赖命令如下:

sudo apt install libssl1.0.0 ocl-icd-opencl-dev

官方推荐安装NVIDIA的闭源驱动。因此对于核显以及AMD显卡的用户,可能会有不可预料的错误发生。

对于安装有NVIDIA闭源驱动的用户(bumblebee方案亦可),再追加以下命令:

sudo apt install nvidia-cuda-dev nvidia-opencl-icd

至此,依赖安装完毕。

三、安装DaVinci Resolve

将下载好的zip解压缩,得到一个.run文件。

在终端中通过 ./*.run 来运行得到的run文件(*对应解压出来的run文件名),一步步安装即可。

安装完成,如果是bumblebee用户,请通过optirun命令来启动。它的启动命令为

optirun /opt/resolve/bin/resolve

一般来讲,应该可以运行成功了。如果出现没有窗口打开的情况,请通过如下步骤检查:

  • 通过终端运行DaVinci (终端命令 /opt/resolve/bin/resolve ) 检查输出的错误信息
  • 确保所有的依赖都已安装。 运行 ldd /opt/resolve/bin/resolve 来查看是否有缺失的库文件 (对于找不到的依赖,ldd应该会在对应行显示空白对应关系)
  • 查看日志文件。位置在 /opt/resolve/logs/ ,有两个需要关注: ResolveDebug.txt rollinglog.txt
  • 确保CUDA和OpenCL安装成功,并且可以正常载入。即使使用CUDA,同样需要一个正常的OpenCL功能。
  • 如果在启动时便发生 Segmentation fault ,一般情况意味着缺失GPU驱动,或使用了不支持的GPU驱动程序或硬件。具体请查看 /opt/resolve/logs/

将.run编辑成.deb安装包进行安装

这很大程度上可以便于补全缺失的依赖 (通过 apt -f install 即可完成)。步骤如下:

  • 去往 https://www.danieltufvesson.com/makeresolvedeb 获取脚本文件。注意这里下载的脚本一定要与自己持有的DaVinci版本相对应。比如现在官网可以获取到15.2.2,则在这里请下载适配15.2.2版本中最新的脚本文件。
  • 补全所需依赖。使用命令 sudo apt install fakeroot xorriso
  • 将得到的 tar.gz 文件解压,文件放到 DaVinci 安装程序(.run文件)相同的文件夹下。这个文件夹一定要在ext4或其他默认权限为755的分区中(NTFS不支持Linux的权限管理,默认为777)
  • 在该文件夹下打开终端,输入 ./"脚本名" lite 完成deb文件的创建

对于Deepin来说,以上是全部过程了。如果在某些步骤中还有缺少依赖的提示,只需通过 sudo apt install 依赖名 补全即可。

创建时间:2019年05月06日
最后修订:2020年01月02日
另请参阅:
DeepinDebianDaVinci Resolve
上一篇
打赏
下一篇

添加新评论

已有 18 条评论

 匿名 12 个月前 • |

链接“https://www.danieltufvesson.com/makeresolvedeb”已经失效了(404)

 等我稍后补充昵称 12 个月前 • |
@匿名

直接装也行 封装只是方便通过包管理器管理而已

 匿名 11 个月前 • |
@等我稍后补充昵称

麻烦你出一期教程,无论是视频教程还是专栏教程都可以

 等我稍后补充昵称 11 个月前 • |
@匿名

现在已经不用deepin了 这个还真没法搞。而且达芬奇的缺失的依赖每个人都不一样,这种教程完全是仅针对自己电脑的,对观众没有什么帮助。包括我的这篇文章也一样

 匿名 11 个月前 • |
@等我稍后补充昵称

既然不用deepin了,要不你把文件发在B站的动态,无论是脚本文件还是deb包都可以;不然的话,也可以发布针对于debian/基于debian系统的安装教程啊!

 等我稍后补充昵称 11 个月前 • |
@匿名

但凡要是用debian分支的系统不就可以搞视频了吗…问题就是用arch,哪里还留着debian的东西了 况且这也不是重点,重点是这玩意就算有教程也是对别人没任何帮助的教程…因为达芬奇的依赖太多,所以到底要装什么,怎么装,全都是因人而异的

 匿名 11 个月前 • |
@等我稍后补充昵称

尽管这样,问题是怎么把.run安装文件编译成.deb安装包?

 等我稍后补充昵称 11 个月前 • |
@匿名

不用啊 .run可以直接运行,和英伟达闭源驱动一样

 228780975 3 个月前 • |

大佬,我的arch kde davinci只要安装了cuda就打不开了,这是怎么回事

 等我稍后补充昵称 3 个月前 • |
@228780975

显卡是啥的,装了啥驱动啊

 228780975 3 个月前 • |
@等我稍后补充昵称

gtx1050 cuda opencl-nvidia nvidia-lts ocl-icd 我用nvcc -V 显示cuda也正常,然而只要装了cuda,davinci就打不开,卸载了用opencl可以进去,但是剪辑的时候没有画面和声音,win10上都正常着,我用的optimus-manager-qt,bbswitch-dkms和acpi_call-lts切换我都试过了

 等我稍后补充昵称 3 个月前 • |
@228780975

没画面和声音不是依赖的问题,是你的视频编码不对。Linux免费版视频不支持h264编码,音频不支持aac。需要转码导入

 228780975 3 个月前 • |
@等我稍后补充昵称

那用cuda进不了怎么解

 等我稍后补充昵称 3 个月前 • |
@228780975

怕不是你的英伟达驱动选错了 内核是什么版本的?

 228780975 3 个月前 • |
@等我稍后补充昵称

内核lts的,其它啥都好着,就cuda有问题,显卡驱动nvidia-lts的

 等我稍后补充昵称 3 个月前 • |
@228780975

那我也不清楚了…要是需要cuda的话,把英伟达驱动换到dkms试试

 Daniel 3 个月前 • |

怎样把deepin改为unstable

 等我稍后补充昵称 3 个月前 • |
@Daniel

使用Ubuntu